Can't Update my Certificate

Hello. My Discourse is up-to-date with version 3.2.0.beta3-dev. Still, yesterday by 5 pm European time the site went down (, and it’s obviously a certificate issue (see attachment. Open in New Tab and enlarge), so, I ran the following code in my console:

cd /var/discourse
git pull
./launcher bootstrap web_only && ./launcher destroy web_only && ./launcher start web_only

However, we can still not log in to Discourse. Two questions:

  1. Shouldn’t the certificate update automatically when Discourse is upgraded?

  2. How can I resolve this, so we can log in again?

Oh no, not again. :slight_smile:

Looking over the topic from the last time the certificate needed renewing, I think it could be that one of the commands from the three didn’t work as expected:

Have you got the output of those handy you could share so we can better see where it’s failing?

1 Like

Who is your Domain provider? Some like Google include ssl.cert.that doesn’t require to renewal.

It looks like your using maybe a free site certificate?

A company I work with uses a free site certificate…And often they would forget to renew it.

In my ss it says it expired. So log into the service that provided cert and renew it.

SSL certificates are generated automatically as part of a Discourse install, and are also renewed automatically.

I think in this case something has gone awry with the rebuild/bootstrap (Wes unfortunately has issues every 3 months when the certificate is due to be renewed).


Okay so.Op is on a Hosted plan vs Self Hosting?

Makes sense. The company I help uses a domain registar that does not provide an ssl cert snd opted to use a free cert service.

In Discourse is that what the lets encrypt section is for an alt build in option for ssl?

No, they’re self-hosted.

It should all be handled by LetsEncrypt unless you opt out of it.

Ah cool. My site was initially setup by a friend vps side…When I changed it from a testing site. Used a domain provider that provides ssl cert. So both my friend and the company rach opted out then. Pain with the company as they are always forgetting often on their end yo renew it.

Thanks for expanding my awareness.


I ran the certificate renewal once more in the console, and now it seems to be working! Must have been a glitch the first time.

Yes, for some reason I apparently need to update the cert every three months, even though I am upgrading Discourse right away when the upgrade is available.

Thanks everybody,

That’s great. :slight_smile: :rocket:

Did you run these again to get it working:

./launcher bootstrap web_only && ./launcher destroy web_only && ./launcher start web_only

Or was it something else?

1 Like

I just ran it again and it worked the second time. Same code.

1 Like

Next time, in two months you should check and not wait until it expires. It would renew after 60 days. Set a reminder somewhere. Uptime robot will send you a reminder I think, but not on their free tier.

Do you use cloudflare or something else on front of your discourse install?

Yes, I will time a timer on this. And no, I don’t use Cloudflare or anything else that I know of in front of my install.

Thanks, Jay.