Discourse Went Down Suddenly. No one can log in

My Discourse at wespenreboards.com has been down for a few hours. Members tell me that some get the error message that the forum could have been hacked. Another says that they get the message the certificate has expired. A third person now gets this message: “FetchEvent.respondWith received an error:no-response.”

When I try to log in myself (I’m the Admin), I just get the spinning wheel. The forum is up-to-date, so the certificate should be also. To be sure I ran this:

cd /var/discourse
git pull
./launcher bootstrap web_only && ./launcher destroy web_only && ./launcher start web_only

But it doesn’t help.

Anyone having any ideas?

Do you have any kind of CDN in play?

If you ssh to your server, and try

wget -q --timeout=3 https://localhost/privacy  -O - |egrep generator

does that work?

How about

wget -q --no-check-certificate --timeout=3 https://localhost/privacy  -O - |egrep generator

How about if you put your full URL in there instead of localhost? Try both versions of the command.

1 Like

Hey Wes :slight_smile:

It doesn’t look like your site is up at the moment. Have you done anything in the meantime?

I’m wondering if you may need to update your data container if it’s not been done in awhile. I’m still a little hazy on the two-container set-up, so I’ll pop an @pfaffman bat signal in as I’m sure he knows more about the rhythm for that. :crossed_fingers: :slight_smile:


Hi Jammy! I remember you since before. I did an update/upgrade in the meantime. That’s all… OK, I’ll wait until pfaffman comes on then.

OK, I’ll try that…

These commands don’t work, but I might do it incorrectly. Do I exchange https://localhost/privacy with https://wespenreboards.com/privacy?

What does /privacy stand for in this case?

Better if you try them first using literally localhost, and then subsequently try them with your actual domain.

/privacy is just a standard page on every forum: what we’re doing here is seeing if the forum is responding at all, locally.

1 Like

This may have updated recently as now the /privacy and /tos pages only appear when company name has been filled in. I don’t know if this would affect the test in this case, but thought it sounded relevant.

There a bit more info on the decision here:

1 Like

OK. So, I tried with localhost/privacy. Then only localhost. Then wespenreboards.com only, and last wespenreboards.com/localhost. The result was the same using any of them:

So there is nothing I need to do with this?

That’s interesting - it’s used in discourse-doctor. So that might need to be updated.

Is that a zero which should be an upper-case O perhaps? Did you also try the versions with --no-check-certificate ?

If /privacy doesn’t work, perhaps try /about instead.

Yes, it’s a zero. OK, I’ll try an O instead and /about.

And yes, I tried the other algorithm, too, but I used a zero, so I’ll do both…

I tried both commands, but it’s not working:

The change to when TOS and privacy pages are created is fairly recent. If your site is not new then it does not affect you.

Not sure how it is used in discourse-doctor. @pfaffman can you weigh in here? Is it used for troubleshooting, or just to verify that the links exist?

We’ll be doing more to educate new site owners about this functionality.

1 Like

ok, so the problem you have isn’t a reachability problem, it’s probably a problem that Discourse isn’t starting up properly. Can you paste the entirety of what you see when you run the launcher start?

It’s used by get_discourse_version which is called by check_if_hostname_resolves_here which may report DNS PROBLEM if the connection to localhost and to the fully qualified domain don’t report the same version. However, it looks like it might be silent if both connections fail. See here.

So how do I run the launcher start? I’m unfamiliar with all this terminology, unfortunately.

Something like

cd /var/discourse
git pull
./launcher start web_only

(Bearing in mind that I’m not personally familiar with the two-container setup that you are apparently using. Also bearing in mind the question upthread as to whether you should update your data container.)


This is how it turned out:


Awesome! I tried to log in, and now it works! Thanks a lot, Ed.

Why did this happen in the first place, do you know?