Changing ownership of a topic doesn’t work

I can’t, as an admin, change ownership of a topic. And safe-mode didn’t bring any clearence. I’m on iPad, so can’t tell if there is any errors in console. Diacourse is upgraded about an hour ago. What else… in that category is no unusually limitations, visible for everyone and writing is for TL1 — but I tried change ownership to staff and ordinary TL1 without success.

I’ve just had a test run and it worked for me on my test site. I could successfully change an OP to a different user.

By any chance, do you have the ActivityPub plugin active on that topic’s category?


Oh damn :man_facepalming: Of course. And yes I have.


That caught me out for some time the first time I encountered it in our feature category. :slight_smile: It’s a current limitation(/feature?) of the ActivityPub plugin, though can be a real puzzler until you click what’s going on. :slight_smile:

I kind of understand it with the very first post, because it is delivered. But I can’t change ownership of any posts under such topic and that bothers me a bit because ActivityPub should not see those - at the moment anyway.

(Let’ connect topics together: ActivityPub Plugin )

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.