Click the edit button on the category page to go to page 404

I know the cause and the temporary solution, but I will report it.

After the update, if any slug in the category is empty, it seems that somehow the encoded string is automatically assigned.

Example

This seems to be happening in a non-English environment. I was in a Japanese environment.
Any slugs will remain empty in the newly created category and there seems to be no problem

For reference, you can go to the edit screen by accessing this as a temporary solution.
Change the value of the number in the category accordingly.
https://example.com/c/5-category/edit/general

I’m not sure if this is just my problem or a common bug, but I hope it helps.

What Discourse version are you on?

I am using the latest 2.8.0.beta2

I installed it for testing in early June and was preparing for production.

cd /var/discourse
./launcher rebuild app

I tried this and it didn’t change.

category-bug

I was able to reproduce it in the above step.
Even with newly created categories, the category edit button causes a 404 error when using Unicode slugs.

Unicode slug example:日本語

Unicode

After this, as shown in the gif of the previous post, clicking the edit button on the category page returns a 404 error.

Hmm, I’m not able to reproduce the 404 with the slug generation method site setting set to encoded. I believe this should be enabled by default when you use a relevant default locale option.

3 Likes

Thank you!

I didn’t like long slugs and had turned it off before.
Selecting’encode’ for the slug generation method resolved the 404 error.
In such a situation, I think that it could be prevented by not accepting multi-byte characters or if there was a cautionary note.

In any case, it’s strange that the encoded string was assigned to the category that was emptying the slug …

Same issue here. I have a category named santé and I guess the é is breaking the redirection to the edition page.
I see this on my console:

Does someone found a solution?

1 Like