Clicking on a category doesn't filter the right topics

Demo Video: Discourse Bug - Album on Imgur

On the first load of the page, clicking on any category name shows the category page with all the topics.

It’s only after the second page navigation that everything loads as expected.


Can you reproduce the issue here on meta?

1 Like

No but I’ve noticed this after I did a discourse update yesterday. I’ve tried this with all the plugins and theme components disabled and it’s the same.

The first navigation to a category page doesn’t show a loader or anything, it seems to just render the latest topics.

No errors in console or in the backend logs either.


@sam you can see the behaviour yourself here -, it’s even happening in safemode:

1 Like

Sorry, can you reproduce this on

1 Like

Nope, unable to reproduce it here.

1 Like

Also happening to me on Was fine until I updated this morning.


My instance of Discourse is up-to-date

When clicking on a category for the time time at, it shows Topics from a different category. And then the second time I go into the category (without reloading page), it shows the correct topic for the thread.

Never experienced this before this latest update I did to my Discourse instance.

And yes I use Cloudflare. However, I was able to re-produce this bug on my backend server IP. So it’s not a conflict with Cloudflare.

1 Like

@wn03 I’ve slipped your report to this topic to keep them together for easier tracking. :+1:

I can’t repro this on my test site so far. Does anyone have any more details that I could use to try something different? Any plugins in common, or any uncommon admin settings perhaps?

1 Like

What’s the default front page of the affected forums? Is it Categories?

(And by default front page, I suppose I mean the default for the affected user…)


I gave it a go, but no joy so far. :man_shrugging:

1 Like

Yes, my site at (rebuilt earlier today) is also misbehaving in this very same way.

Here is my current Plugins list…

You can see in the following 2 images that they are showing the same URL…

However the first image (erroneously) shows all Topics…

While the second image properly shows just Topics in the “Tech News” Category…

After the first click on the Category “Tech News” (erroneously showing all Topics… )

After the second click on the Category “Tech News” (or next refreshing the page)… just Topics in the “Tech News” Category are properly displayed…

You can try reproducing this on my site…

  1. Click the Tech News category at the bottom of the Categories drop-down, and then click it a second time (or then refresh the page.) You can see it changes from showing all Topics to properly showing only the “Tech News” Category Posts.

  2. Now go back to the site home page (which I have set to the Categories page on this site) and do it again.

The very same behavior occurs with the Tags drop-down on the Categories page.

Besides the Categories page, all the rest (Latest, New, Top) are behaving correctly on my site.

Only 3 of the 8 desktop category page style settings are showing this behavior:

  1. Categories and Latest Topics (sort by created date)
  2. Categories and Latest Topics
  3. Categories and Top Topics

OK - I’ve now disabled every Plugin and run ./launcher rebuild app and the behavior persists.

Or might a specific Theme Component be the culprit?

I have now also tried disabling all Theme Components but the behavior persists.

Could an installed but de-activated Plugin or Theme Component be the culprit?


That’s a bunch of plugins that could be the culprit. I imagine that the issue is with one of those.

1 Like

Just a little update, I have replicated it a couple of times on my test site, but not consistently enough to get repro steps/any deeper insight.


I’ve up-dated my post at Clicking on a category doesn't filter the right topics - #13 by denvergeeks above with my attempts at de-bugging.

I hope it is helpful.

Please let me know any further steps I can take, or questions I can answer, that might help resolve this…

Over the last week or so we’ve had a whole bunch of people reporting that when they click on “Unread” our Discourse is now showing them a mixture of both read and unread topics.

Is this all related?

And then if they reload they get the expected four unread items:


I can confirm that my site does also show all posts (both read and unread) when I click on Unread.

I agree that these might be related because the behavior seems the same:

The first click shows all posts, but if next I refresh the page (or next click the button a second time) then the results are correct.

Seems like a caching-related issue, no?

1 Like

Something is certainly not feeling right here.

A repro on meta would be mighty handy if someone can figure out how. Regardless I have pinged some devs that worked on this code recently in case they have any ideas.


OK I tried, but since meta is not running one of these 3 category page styles I can’t think of a way to repro on meta.