Strange behavior of the navigation by clicking on the (none) category


(Руслан Корнев) #1

Hi, i found strange behavior of the navigation by clicking on the (none) category.

Here is the way to reproduce it

  1. Follow to https://meta.discourse.org/c/extensibility
  2. click on (none) category
  3. click again on (none) category

You will see that pages on 2. and 3. steps are different.

  1. step

  1. step


(Jeff Atwood) #2

There is already a bug on this, the only difference is the topic excerpt for the pinned topic does not display, yes? Other bugs on this, same thing.


(Руслан Корнев) #3

Sorry not sure that i understood you correctly.

  1. I thought that (none) category should display topics which assigned only to first level categories (extensibility). But on the step 3. displaying (all) topics which assigned to (plugin) os (sso)
  2. Anyway double visiting same page should lead to same results, isn’t it?

(Jeff Atwood) #4

Oh my bad, you are correct. I should have looked closer.


(Florian) #5

I was about to report the very same issue (the excellent search function brought me here). The bug is still present in latest Discourse (2.0.0beta10).


(Joffrey Jaffeux) #6

So what I see here is that the second click on none is basically doing a “all” instead of a “none”. Will see if I can fix this.


(Joffrey Jaffeux) #7

This should be fixed by:

While it’s not exactly fixing the issue, it will not show “none” anymore if you already are on none, preventing this issue from happening.


(Joffrey Jaffeux) #8

This topic was automatically closed after 25 hours. New replies are no longer allowed.