Copy quote functionality

In the last week or so the little popup to quote a previous post has gotten difficult to use on our hosted instance. Sometimes it sticks around, but more often lately it flicks away just when you want to use it


Can other people play the video? It’s just a black rectangle for me and I’m not sure whether that’s a problem with the video or my company’s “secure” browser. I re-uploaded and it looked fine before I closed the window & now it’s a black box again. :frowning:

Hi @ganncamp the video works for me. I haven’t been able to reproduce your quote issue yet though :thinking:

1 Like

Hi :slight_smile:

Does the problem persist in safe mode?

No. There’s a brief hesitation before the popup appears, but it’s there reliably

@ganncamp is this still persisting for you? Or did you find a culprit/fix?

I have logged in on your forum but still cannot seem to reproduce the issue - the select text quote/share feature is working as expected and the selected text doesn’t act “coy” :grin: like in your sceen video :thinking:

I’ve tried in Safari iOS on ipad, both desktop and mobile, as well as Chrome and Firefox desktops in Linux Ubuntu but seemed to work normally for me.

Hmm… Just like when your car won’t make the weird sound for the mechanic, it seems to have cleared up over night. :smiley:


Aaand… now that I’ve driven away from the mechanic, it’s doing it again. :roll_eyes:

1 Like

Hi @ganncamp,

I think I’m able to replicate what you’re experiencing, here on Meta.

If my starting point when I select text is within the content area of the post, then the quote button presents itself.

However, if my starting point when I press my left mouse button to select text is outside of the content area of the post, then I’ve “selected” some area in a different div element, and the quote button is not usable.

I’ve tried to demonstrate in this little screen capture with the following behaviors:

  1. Select text from only the content area. – Quote button is presented
  2. Try to select text beginning outside the content area, under @Lilly’s avatar. I had the mouse high enough up that even Lilly’s username was selected, so I was clearly outside of the post’s content area. – No Quote button
  3. Begin selecting text just outside of the post’s content area. – Unusable Quote button
  4. Repeat 3 for good measure
  5. Repeat 1 for good measure

Can you confirm that if you are careful to start selecting text only when the mouse is within the post’s content area, the Quote button is usable?
If so, I’m not sure if we’d consider this a bug, as we’d only expect to quote text from within the post.

1 Like

More specifically, the popup is triggered each time the selection changes if we started dragging the mouse from outside the content’s container:


I’d classify this as a small bug.


@Southpaw what browser is that? I have tried to reproduce this many times, including exactly as you are and I cannot on Meta or any of my instances or browsers. :thinking: I can do the effect that @Canapin just pointed out though.

I’m using Linux Ubuntu with Chrome and Firefox, and iOS 16 with Safari on iPad.

I’m again unable to reliably replicate this at the moment, whether I start selecting from within (I guess. I can’t see it. :joy:) the content area or outside of it. Once out of… 30? tests, I failed to get the popup. For the rest, I see a little flicker sometimes, but by the time I’m done selecting, the popup is steady and available (at the moment) :roll_eyes:

1 Like

I can’t get the effect @Canapin demonstrates. :thinking:
I’m using Chrome (which updated last night after I took the screen capture, but with no change in behavior) on a MacBook Air, Sonoma 14.0

1 Like

I can reproduce both following the steps above:

  1. Select just far enough outside to break it
  2. Highlight moving flickers
  3. Letting go of the mouse removes the pop-up

I think I can repro this in Chrome but not in Firefox. Firefox refuses to let me select from “outside” it selects too much, but chrome allows it.

If you select from the outside all this flashing and weird events happen:

1 Like

This feels like it is floatkit related.

We are not capturing and stopping propagation outside of the element and we can do the dragging outside of it… Its like we need a global thing that stops all of the propagation and that is not happening cause we only stop it here:


Latest fixes by @joffreyjaffeux appear to have this all sorted.

@ganncamp I just kicked off a deploy, should be on your site, can you let us know if it is looking better?


So far so good, but I haven’t tried a lot of quoting yet.

I want to hold off a day or too before I give a :+1:


Well… it’s hard to prove a negative, but it looks like this isn’t messing up any more. Thanks!


Thanks for trying, you can change your mind if necessary :wink: