"Currently upgrading" even after a rebuild


(Allen - Watchman Monitoring) #1

I’ve just given a discourse I manage the three command solute:

  • cd /var/discourse
  • git pull
  • ./launcher rebuild app

The rebuild appears to go well, I can log in, etc. however- the admin panel still says “upgrading” and will not accept a click to upgrade routine.

What can be done to reset this?

(FWIW This is the same instance that ran out of room during a previous one-click upgrade via the Admin panel.)


(Kane York) #2

We should have the rebuild clear the upgrading flag in Redis.


Discourse stuck on "Currently Upgrading"
(Jeff Atwood) #3

Yeah just stop and restart the docker container. Or reboot the server.


(Allen - Watchman Monitoring) #4

I’d already rebooted the host before posting, no change.

./launcher restart app didn’t change the “upgrading” status either


(Sam) #5

I’ve had the same issue once after the upgrade process stalled and I had to rebuild - the “Upgrading…” status didn’t clear until I hit the “Reset Upgrade” button and then everything cleared up (no actual reset process seemed to take place, it just cleared the “phantom upgrade”, so to speak).

Would advise caution / checking with folks more knowledgeable about the system before trying this, though.


(Jeff Atwood) #6

Any comment on this @eviltrout? Anything we can do here?


(Robin Ward) #7

Had you started an upgrade in the web side before you did it on the command line? I’m just trying to understand how the flag got stuck in that position.

The easiest way to unlock it is to flush redis.

$ ./launcher enter app
$ redis-cli flushall

Discourse stuck on "Currently Upgrading"
(Allen - Watchman Monitoring) #8

This was the discourse which failed an upgrade partway through due to lack of space.

Per @Yuun’s suggestion see that I can click on the initial Currently Upgrading... at /admin/upgrade. It certainly didn’t look clickable.

There I see the Reset Upgrade button, which I assume would work, but haven’t tried until this troubleshooting thread is complete.

Let me know which would be more useful to try first - the reset button or flushall.


(Allen - Watchman Monitoring) #9

I went with yuun’s idea and clicked reset backup.

The git-reset looked like it had a Lot of files to change for being just 52 commits behind, and it had to bundle a lot of stuff… took about 3x longer than expected.

However, it made it through Ok.

I guess all that’s left to do here is have a rebuild clear any “currently upgrading” flag.

Thanks for the tips and advice.


(Sam) #10

I’m glad it worked - difference in post-reset-button-pushing experience likely down to where the upgrade failed?

As a betting man I’d probably have gone with the discourse dev team’s suggestion over mine, but I suppose everything turned out fine.


(Allen - Watchman Monitoring) #11

heh, clicking buttons in the UI the team built isn’t really gambling… I just didn’t see that because I didn’t think the “busy upgrading” button was clickable.

The underlying issue is that, after a failed rebuild (no disk space in my case) a full rebuild didn’t clear the flag.

I think once that’s accounted for, we’re good here.


Upgrade "currently upgrading" forever
(Jeff Atwood) #12