Digital Ocean Installation


(Chris Malone) #1

I have three installs of discourse on Digital Ocean. They are all either $15 or $20 droplets. I want to start working on a new project and have read that discourse can be installed on a $5 droplet. CAN be and SHOULD be are different things. Will it run without server errors or running out of memory on their lowest level droplet? (2GB RAM, 25GB sad, one cpu)


(Stephen) #2

Yes, assuming you’re hosting moderately sized communities.


(Chris Malone) #3

I’ll give it a try. Thanks.


(Jay Pfaffman) #4

I have done installs on 1GB droplets for a couple hundred people, most of whom are still doing just fine. I require a 2GB ($10/month) droplet for people who have many plugins.


(Chris Malone) #5

Thanks very much. That makes me feel confident to try it. About to start it.


(Justin DiRose) #6

I just spun one up on a $5 droplet as a personal instance with no issues, including sharing a server with a small Wordpress site.


(Chris Malone) #7

So I set up a $5 droplet. I am constantly getting 502 server errors. Especially, but not only, when I am trying to save admin settings. No particular setting. I can be doing anything and then WHAM. Is it likely a fault in the install or a problem with the server? I’m running my dns through cloudflare. I’m running ssl through letsencrypt through the app.yml file.


(Jay Pfaffman) #8

Cloudflare is DNS only? Do you have plug-ins installed?


(Chris Malone) #9

Cloudflare is DNS only. I have the setting ticked to “require https”, also. No plugins at all.


(Chris Malone) #10

But there is no reason to do that since I have “force https” set in Discourse. I have disabled that in Cloudflare. Do you think that would have caused the issues, @pfaffman?


(Jay Pfaffman) #11

If Cloudflare is DNS only, then no Cloudflare settings should matter. If you do a dns lookup for your site it resolves to the IP of your droplet?


(Chris Malone) #12

It does come up with the correct ip address.


(Chris Malone) #13

I think I’ll try “rebuilding” the app. Maybe that will do something good.


(Chris Malone) #14

Not good:

Here’s what I got when I tried to rebuild the app.

./launcher rebuild app
/usr/bin/docker: Error response from daemon: OCI runtime create failed: container_linux.go:348: starting container process caused “process_linux.go:402: container init caused “process_linux.go:385: running prestart hook 0 caused \“error running hook: signal: segmentation fault, stdout: , stderr: \”””: unknown.
Your Docker installation is not working correctly

The fourth time I tried it began the rebuild. Should I destroy the droplet and start over?


(Chris Malone) #15

Could not load list of meta packages: [Errno 12] Cannot allocate memory
Could not load list of meta packages: [Errno 12] Cannot allocate memory

I think my server is toast.


(Jay Pfaffman) #16

Looks like a ram problem. Do you have swap? Is there other stuff installed?


(Chris Malone) #17

No. Nothing besides discourse. I used their one button install. That’s the only thing that I did differently than ever before.


(Jay Pfaffman) #18

You should follow the standard install instructions. That will configure swap and you can use a 1gb droplet.


(Chris Malone) #19

I’ll destroy this one and start over and install the way I usually do. (Which is by the directions.). Thanks