Disabling emoji auto-complete as a user

Hi :slight_smile:

I would like to be able to disable emoji auto-complete as an user, please. :slight_smile:

Please see Disabling emoji auto-complete and Disabling smileys (on discourse.gnome.org).

Could you include a brief summary of the issue you’re facing/why this user preference would be beneficial here in the OP as well. It makes for a much more well-rounded feature request (and saves people hunting the info down in links :slight_smile:)

(what is OP?)

OK, I’ll try it.

  • As french, I sometimes type <space>:<return>. (<return> wants to make a new line, not validate a suggested emoji.)
  • I also often type smileys, notably “:-)”, and still at the end of a line. It is converted in ":slight_smile: ". I don’t like that, because, even if it gives the same result, it makes it harder to review the message before posting it.
  • I’m a discourse.gnome.org user, and they tell that they can’t help me because it’s a site-wide setting. That’s why I would like you to make it an user-wide setting, please. :slight_smile:

Alternative: You could find an other way to validate a suggested emoji in the auto-complete feature (maybe <tab>?), so <return> will be considered as continue typing, ignoring suggestions, like <space>.

1 Like

Original Post = the first post in the topic, the one that sets the topic title like yours that started this one

so why not just hit :spacereturn?

If you put a space after the colon the auto-complete emoji pop-up should close immediately.

3 Likes

Sorry, does that mean I should edit the 1st post instead of put it below it?

As a dev, I hate to let lost spaces where they are useless. I find it’s dirty work.
So I have the habit to type <space>:<return>, and I wouldn’t very much like to acquire the reflex of <space>:<space><return>.

<space>:<space><backspace><return> doesn’t work, too, since it opens the auto-complete box again.


The point is: I have the habit to type <space>:<return> in any plain text editor, and I would like very much it gives the same result in Discourse. That is, all these keys would be considered as typing flow / text flow (not only <space>), so auto-complete suggestions would have to be ignored.

Why not use <enter> instead of <return> (the one on the numeric part of the keyboard)?
Since it uses <arrow-up> / <arrow-down> to choose the emoji, it could also use <arrow-right> to validate it, given that <arrow-left><arrow-right> does not open the auto-complete box again.

hmmm, sorry, I am not following your argument. Just to clarify - I gave you a simple solution, but you are saying it is not good enough because you have habit of using :return; so you feel that we should introduce a new functionality to user preferences for this? FWIW, I don’t believe I’ve seen this particular feature request yet. :thinking:

Thanks for the workaround. :slight_smile:

  • and :<space><backspace><return> is not a workaround,
  • and I wouldn’t like to acquire the reflex of :<space><return> and type it in any plain text editor, because it would make dirty work, particularly in code and official doc.

What’s the new functionality?

What I understood is: There is already a site-wide setting, and I suggest to make this setting user-wide.


I just discovered that GitLab also has an auto-complete feature, similar to Discourse one, except that there is no selected emoji when it opens the auto-complete box, so the user has to type <arrow-down> to choose the 1st suggested emoji.

Then, :<return> is considered as typing flow / text flow, and auto-complete suggestions are ignored.
It opens the auto-complete box even when : is typed after letters, and I don’t think it bothers anyone. :slight_smile:

Users have to type <arrow-down><return> instead of <return> to get the 1st suggested emoji.

Would you find this change acceptable?

What about space : escape return as a workaround? It seems to work for me in testing, but it might be easy to accidently minimize the composer.

1 Like

Thank you very much, it seems to be a great workaround. :slight_smile:

Please keep in mind either the GitLab solution or user-wide disabling, so I would no longer need to insert <escape> in my typing flow. :slight_smile:

1 Like