Emojis autocomplete issue with "emoji autocomplete min chars" > 0

I believe it happens since a recent upgrade (2.5 to 2.6.0.beta1).

If there is any text in front of the same line (even just a space), hen I start to write : following by letters or keywords, autocompletion won’t be displayed.
However, if I start to delete letters after :, then the autocomplete is displayed.

If I type : on a new line, it works perfectly.

Here I show the 3 cases:

  1. writing an emoji as the first line element (shows the autocompletion)
  2. writing an emoji after existing text (don’t show the autocompletion)
  3. removing a character (shows the autocompletion)

TbHGrhYEvP
I tried in safe mode and it didn’t fix the issue.

edit: the issue disappears if I set emoji autocomplete min chars to 0.

5 Likes

I barely recall someone complaining that accented characters and emojis don’t play nice. It may have been related to that fix but This is language specific, can’t reproduce this in forums on english language.

2 Likes

I didn’t encounter this issue before and it happens without typing accented characters in the keywords though. Also, enable inline emoji translation is disabled.
I upgraded another Discourse installation and the same issue happened, so I guess that’s related to both this setting and the new version.

1 Like

I can’t reproduce this here on meta? I have text on the same line, followed by :, and I get emoji autocomplete just fine?

1 Like

Did you change the emoji autocomplete min chars setting to 1? I don’t have the issue when it is set to 0.

2 Likes

My setting was set to 0 by default and we’ve never had a problem. :slightly_smiling_face:
Edit: I changed my setting to 1, tried it on a reply post and it still worked fine.
Edit2: FYI, my site is in English.

I think you’re right, I can repro on my instance (2.6) which is in french, but the issue occurs even if there are no accented characters written on the line as canapin said.

And it works fine on another one, 2.5.0.beta6, also in french

3 Likes

I’ve noticed the :t2: skin tone suggestions stopped working a while ago too. Is this related?

Even on here on meta :+1:t2:

A single colon starts the suggestions fine:

Then I press Tab or click the suggestion I want.

I then type another colon to change the skin tone.

Put I get no prompts or suggestions now:

If I manually type in the skin tone it does actually display correctly.

:man_shrugging:

4 Likes

Very nice catch @canapin with excellent repro steps.

Fixed per:

6 Likes