Discourse comments not showing up on pages - only posts

Maybe I’m missing something… I’ve got WP Discourse plugin working with SSO and it appears to be working fine enabling comments on POSTS but not PAGES.

I haven’t found something that says it only works on posts. Does it work on pages? If so, what do I need to enable?

Test post - which is working as desired:
https://www.testconx.org/premium/2020/test-of-a-post/

Test page - which is not working:
https://www.testconx.org/premium/another-page-test/

For debug, I disabled WP Discourse plugin and the comment box showed up correctly on the the test page. After which, re-enabled it.

Any pointers, would be appreciated!

Thanks,

Ira

1 Like

You’ll get a real answer from someone who knows soon, but I’m pretty sure that in the plugin settings there is a place that lets you choose posts, pages and other types.

2 Likes

On the WP Discourse Publishing Settings tab, you need to select both ‘post’ and ‘page’ in the “Post Types to Publish” setting. That setting is found near the bottom of the page.

If you have enabled ‘page’ on this setting and are still not able to publish pages to Discourse and have comments show for them on Discourse, let me know and I’ll look into what is going wrong.

1 Like

@Simon_Cossar: perfect, this did the trick. Thank you! Sorry for having overlooked this setting.

1 Like