Discourse Official Installation "No such file or directory"

While installing a new instance of Discourse on a freshly installed Hetzner server with the following specs:

As directed here…

…and following those instructions here…

…like so…

…I am getting the error:

fatal: repository ‘https’ does not exist
bash: //github.com/discourse/discourse-docker.git: No such file or directory

I would appreciate any help!

I can’t quite make sense if it. My best guess is that you somehow copied some invisible character between the colon and the //.

Maybe try typing the command. Or if you typed it, try copy and paste.


It looks like you typed https;//github…


Yes, thank you @pfaffman and @Moin you were both correct… I had copy/pasted the command

https://github.com/discourse/discourse.git /var/discourse into the web-based console in Hetzner

I tried typing it into the console instead, and indeed that worked!


This is a trap. Hetzner’s web console uses German :de: keyboard layout :slight_smile:
Maybe your issues came from here.
I use it only to change the root’s default password when not using SSH.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.