Install Discourse in production with the official, supported instructions

If you want to install Discourse the official, supported way, have a look at the install Discourse document on Github. If you install Discourse any other way, you’re likely to have trouble, and if you do, you’ll be less likely to get any help here.

This guide covers the official guide to install Discourse which can be used on your bare metal hosting or the cloud. If you have issues with your installation, feel free to start a topic over at our #installation support category, and someone from the community will help.

Alternatively, if you wish to try out Discourse without installing you can visit Discourse pricing | Discourse - Civilized Discussion and start a free hosted trial.


Am not sure if clone was successful, looks like that worked but setup won’t launch says can’t find file/directory:

This is for servers in Toronto (digitalocean).

1 Like

You need to enter discourse_docker directory.

cd discourse_docker

I don’t know if it’s intended, the default clone output directory is usually /var/discourse following the documentation.


Thanks, works now!


Install completed but activation e-mail isn’t working, is the SMTP “token” supposed to be set for the password in setup or is token not password?

May need to setup different mail server account not sure if protonmail is compatible or not.

Troubleshoot email on a new Discourse install

1 Like

Thanks, says SMTP server connection is successful but there is a problem with the sender address, need to change that.

Had wrote “notifications@community.(domain)”, but says "sender address rejected: not owned by user (“account”@(domain)).

Might try rebuild with different domain.

Don’t do that unless you want to make the web server stop working. Don’t do that.

Oh ok don’t want to stop server from working won’t do that.

Does that mean servers can only work with one domain?

Am starting over with new droplet for a .com domain hopefully can make this work today might need some help. Initial process seemed to be working but then the console crashed when I wrote in SMTP mail password (for mailgun) for some reason. Will try again after lunch.

New Install seemed to work, but site hasn’t published.

Last line completed reads: “Background saving terminated with success.”

Had to wait awhile for install to move past that step, said there was an unusual delay with a broccoli tree, lol.

Now site has launched, success!!

1 Like