Docker bootstrap failing with exit 137


(Ankur Sethi) #1

Hello,

I’ve been trying to install Discourse inside an Ubuntu Precise VM (running on VirtualBox) using these instructions. The process fails while running ./launcher bootstrap app with the following output:

/pups/lib/pups/exec_command.rb:85:in `spawn': cd /var/www/discourse && sudo -E -u discourse bundle install --deployment --verbose --without test --without development failed with return #<Process::Status: pid 257 exit 137> (RuntimeError)
    from /pups/lib/pups/exec_command.rb:55:in `block in run'
    from /pups/lib/pups/exec_command.rb:53:in `each'
    from /pups/lib/pups/exec_command.rb:53:in `run'
    from /pups/lib/pups/command.rb:6:in `run'
    from /pups/lib/pups/config.rb:85:in `block (2 levels) in run_commands'
    from /pups/lib/pups/config.rb:76:in `each'
    from /pups/lib/pups/config.rb:76:in `block in run_commands'
    from /pups/lib/pups/config.rb:75:in `each'
    from /pups/lib/pups/config.rb:75:in `run_commands'
    from /pups/lib/pups/config.rb:71:in `run'
    from /pups/lib/pups/cli.rb:31:in `run'
    from /pups/bin/pups:8:in `<main>'
3bc24de467160ae901711cf5009ff9afa1c9178c03bf95ff200a184f81793ad8
FAILED TO BOOTSTRAP

What could I be doing wrong? Is there any more information about my environment that I can give you to help you diagnose this issue?

EDIT: is there something that’s very specific to DigitalOcean in these instructions?

EDIT 2: I just tried the “advanced” guide, with the same result.

Thanks.


(Ben T) #2

How much memory have you given your VM? It sounds like you’re running out of memory.


(Ankur Sethi) #3

That did the trick. Thanks!


(Kane York) #4

Ooh, didn’t know that exit code 137 meant the process was KILLed (here, by the oom-killer)! Learn something new :smiley: