Email for completion not sending because smtp are not correct

Hi! I just installed Discourse and my STMP Details are correct but I still do not get emails I reran everything.

My details were:

Then I used a mailgun account for the rest it was like
^ This is a fake

But I still do not recive any mail…

I was wondering if anyone could help?

Have you tried ./discourse-doctor
Also you should read this.

Yes I have and I did read it but it did not work.

Have you gone trough other topics like this one?

1 Like

Yes I have gone through other topics like that!

This is how it looks

Is there a way that I can bypass the email verification just for the installation completion?

Im not sure if it is throwing my emails away

No. am not a 100% sure tho.

I’ve been trough the installation at least 50 times.
If you follow the official installation guide it should work. could be a miss typo and in a lot of my cases a fresh install and make sure all DNSs are correct should do trick.

They are I copied all the details from mailgun its self its worth to mention I did not do verification with a credit card

If the domain is new today the DNS propagation might still be in progress. That could take up to 72 hours but often less.

If not you should wait for someone with proper skills to help you out. :blush:

Also my server is a very secure one and discourse doctor says

sudo: unable to resolve host Name or service not known

Timeout to open TCP connection to (exceeds 5 seconds)
Thats another error

It should be not stmp - I’ve corrected your title!


If it’s the sandbox then you need to do what’s required to configure it. The sandbox will be able to send only to you, and then you’ll need to do this all over again when you want to have a forum that other people can use.

1 Like

Alright how do I configure it to send only to me?

Ok so I added my email and stuff but it still won’t send

You can check your logs at mailgun. If you’re not getting a bad password error then you’re likely sending from an address that mailgun is not configured for. You need to set the NOTIFICATION_EMAIL to whatever you configured mailgun for.

1 Like

Alright will try Tommorow and will let you know the resaults

How to check logs at mailgun

Would it be possible to use my domain ok free plan aswell

And what do u mean bad password error

i redid it still not working

Hi! It’s very straightforward. Have you tried looking by yourself before asking? :slight_smile:

Log in to Mailgun. Select the right domain. Then click logs in the left sidebar. Pretty much everything is in the sidebar. :slight_smile:

1 Like

yes i have tried looking before asking