Error exporting CSV or JSON from Data Explorer plugin

After creating a query in Data Explorer, when I click on either the JSON button or the CSV button I get an error. The CSV button takes me to /admin/plugins/explorer/queries/4/run.csv?download=1 and that page shows an “Oops ! That page does not exist or is private” error. The JSON button goes to /admin/plugins/explorer/queries/4/run.json?download=1 and that gives me a JSON document:
{“errors”:[“The requested URL or resource could not be found.”],“error_type”:“not_found”}

I have seen the other post on these boards about Data Explorer cannot export to CSV. But my problem is not similar to that. I don’t have any 500 errors, nor are there any errors in /admin/logs

Any help getting CSV or JSON or both to work would be much appreciated.

I’m running the latest version of Discourse 3.2.0

Hello and welcome @Arun_Kumar :slight_smile:

Both seem to be working fine for me here on meta.

Could you try updating to Latest from your /admin/upgrade page and see if that helps?

1 Like

Thanks @JammyDodger ! I get the same error message when I try to access /admin/upgrade. “Oops! The page does not exist or is private”. And yes I am logged in, I’m able to view /admin and see all the pages there. Our discourse instance is hosted on if that makes a difference. When I login to their panel there and look at the software tab, it shows the latest version as 3.2.0.

1 Like

Ah, if you’re hosted by Communiteq then they likely manage your upgrades.

Let’s pop a @RGJ in and see if they can assist. :crossed_fingers:

1 Like

They are on Data Explorer ebe71a7 which is the latest version for 3.2 stable.

FWIW I have seen exactly the same behavior on a CDCK-hosted site about two weeks ago. Just when I started to make a screen recording in order to make a bug report, the issue went away.

@Arun_Kumar can you try refreshing your browser and/or logging out?


Hi @RGJ , i tried to logout, restart the browser and then log back in. But the same error persists.

@RGJ found out the problem is with the popup blocker on my Firefox browser. When it was blocking the popup it was not allowing the download to happen. By allowing all popups from the domain, this functionality works. Thanks @RGJ and @JammyDodger for your help!


See also Data explorer uses popup for download


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.