External links are not opening in new tab


(Jabra) #1

Even after doing these settings, my links are opening in same window. What to do?


(cpradio) #2

That just updates the setting for any new user registrations, you must update it in your User Preferences too.


(Jabra) #3

Thanks, where can I find this option?


(cpradio) #4


(Jabra) #5

Hi, I’m not able to find any such options in settings.


(Jabra) #6

Basically, I have setup discourse and want all users who click any link redirect to new tab. But I’m not able to do this.


(Neil Lalonde) #7

The screenshot @cpradio is showing are from your user preferences (/my/preferences). Whether links should open in another tab or not is a personal preference, although you can set the default for new users.


(Jabra) #8

Already did, but it’s not working :frowning:


(cpradio) #9

What do you see on your user preferences page?


(Jabra) #10

As you said earlier, it’s working for individuals who have ticked “open links in new tab” through their user preferences.

But I want these settings globally. Whenever any user clicks any external link, it should open in new tab.

I’m using following settings but it is not working.


(David Taylor) #11

Changing the “default other external links in new tab” site setting will only take effect for new users. To manually change all existing user’s preferences, you can follow the instructions here:


(Régis Hanol) #12