Failed to bootstrap, also 500 error loading any page


(Rob Reed) #1

Received bundler out of date message updating Discourse, so I built the container as advised. That seemed to work except that I got a message that there was already a server running on port 80. Tried rebooting the server. Now server’s throwing off a 500 error loading any page.

Admittedly I’m out of my depth with docker and discourse.

Tried rebuilding container bc… no good reason which generates the following error.

FAILED
--------------------
RuntimeError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 297 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["su discourse -c 'bundle install --deployment --verbose --without test --without development'", "su discourse -c 'bundle exec rake db:migrate'", "su discourse -c 'bundle exec rake assets:precompile'"]}

I’m open to any suggestions. Thanks in advance.


Seeing repeated "[object object] flag it too" string below Reply line
(Matt Palmer) #2

What do the previous errors say?


(Rob Reed) #3

Rerunning ./launcher rebuild app, the only errors…

database "discourse" already exists
...
role "discourse" already exists
...
column "like_notification_frequency" of relation "user_options" already exists
...
StandardError: An error has occurred, this and all later migrations canceled:
...
FATAL:  xlog flush request 0/E91964B8 is not satisfied --- flushed only to 0/E9159030

and the process ends

2016-03-02 23:41:44 UTC [67-6] LOG:  abnormal database system shutdown
195:M 02 Mar 23:41:44.148 # User requested shutdown...
195:M 02 Mar 23:41:44.149 * Saving the final RDB snapshot before exiting.
195:M 02 Mar 23:41:44.271 * DB saved on disk
195:M 02 Mar 23:41:44.272 # Redis is now ready to exit, bye bye...

Thanks


(Matt Palmer) #4

Something really bad is going on here. Your database is in a completely pantsed state. xlog flush request is not satisfied smells… diskspacey, maybe? At any rate, you’ve broken something real good. How’s your backups?

Please paste the output of df -h, free -m, docker info and docker version.


(Rob Reed) #5

Ha :slightly_smiling:

I have a snapshot from like December. I have a Discourse backup from today, yesterday, and so on.

df -h
Filesystem                 Size  Used Avail Use% Mounted on
udev                       486M     0  486M   0% /dev
tmpfs                      100M  8.5M   91M   9% /run
/dev/disk/by-label/DOROOT   30G   16G   13G  57% /
tmpfs                      497M     0  497M   0% /dev/shm
tmpfs                      5.0M     0  5.0M   0% /run/lock
tmpfs                      497M     0  497M   0% /sys/fs/cgroup
tmpfs                      100M     0  100M   0% /run/user/0


free -m
             total       used       free     shared    buffers     cached
Mem:           993        466        526          7         61        238
-/+ buffers/cache:        167        825
Swap:         2047          0       2047

docker --info
flag provided but not defined: --info

docker --version
Docker version 1.9.1, build a34a1d5

Thanks again.


#6

If you have a recent backup maybe this could help :

(Source)


(Rob Reed) #7

That worked. Thanks for all of your help @mpalmer and @Steven. The outcome wouldn’t have been as good without you.

I’m stuck with an original issue that started me down this path in the first place, but that’s another issue.

To be clear, I consider this issue to be resolved.

Cheers


(Jeff Atwood) #8

Also that should have been docker info not docker --info sorry about that. I guess in the future it’s just

docker info
docker version

that seems to work on my box.


(Rob Reed) #9

Yep that works for me. That was my fault.

docker --help clearly makes a distinction between options and commands.