Failed to Bootstrap

Hello everyone!

After I enter the CDN URL, I executed the below commands:

cd /var/discourse
./launcher enter app
bundle exec rake posts:rebake

Now the site is showing a white-screen error.

I tried to rebuild using the below commands:

cd /var/discourse
git pull
./launcher rebuild app

Now, this error comes:

I don’t have any backups since I just finished setting up, added all categories! 2 days of work!

Please help!


You should be able to start things back up with

  ./launcher start app

and then make your backup!

I also just got a rebuild error related to yarn:

"lodash@4.17.21\" is incompatible with request
ed version \"lodash@4.17.15\"", "warning \" > @mixer/parallel-prettier@2.0.1\" has unmet peer dependency \"prettier@^2.0.0

I’m looking further to see what it might be.

I just rebuilt again and it worked, so perhaps something that was broken got fixed…so you might just try to rebuild again after you make that bacukp!

Thanks for the help. Unfortunately, it is not working. Still blank screen :frowning:

Sorry you’re having trouble.

I’m looking for testers for, my new tool to manage self-hosted sites. If you’ll create an account there, click list servers and then Free! Manage Existing Server and follow the directions there to add the ssh key to your server so that pfaffmanager can do a rebuild, I’ll help figure out what the problem is.

Now the site is online but still see the error in the console. I’ll create an account and follow your instructions!

1 Like