Failed upgrade: docker manager

I’ve just tried upgrading Docker Manager, and it failed with the following:

$ cd /var/www/discourse/plugins/docker_manager && git fetch --tags --prune-tags --prune --force
$ cd /var/www/discourse/plugins/docker_manager && git reset --hard HEAD@{upstream}
HEAD is now at 4c550d5 FIX: Hide this plugin from the plugin list (#199)


/var/www/discourse/lib/discourse_ip_info.rb:48:in `mmdb_download': undefined method `path' for nil:NilClass (NoMethodError)

    filename = File.basename(gz_file.path)
	from /var/www/discourse/lib/tasks/maxminddb.rake:67:in `block (3 levels) in <main>'
	from /var/www/discourse/lib/tasks/maxminddb.rake:65:in `each'
	from /var/www/discourse/lib/tasks/maxminddb.rake:65:in `block (2 levels) in <main>'
#<RuntimeError: RuntimeError>

I’d appreciate any assistance you can give

Could you try a command line rebuild?

I’m nervous to try that, as it’ll take down the whole forum if it fails, will it not?

It will, though you could restart the pre-rebuild version with ./launcher start app.

I think your maxmind database needs a command line rebuild to renew itself.

1 Like

a ./launcher rebuild app fixed it for me - thank you @JammyDodger :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.