Upgrade docker_manager stuck - 2.2.0.beta4


(Zach Nedwich) #1

Hi all,

I’ve just tried to upgrade from 2.2.0.beta3 to 2.2.0.beta4 however Docker Manager would not upgrade at all. The Docker Manager screen shows an empty console and ‘Upgrading…’. Pressing Reset Upgrade throws a JS error (see screenshot). There’s nothing in syslog. The machine has 4GB ram & 4GB swap. I ran ./launcher rebuild app and the upgrade worked but I’d love to keep using Docker Manager. Any ideas?

!

Thanks,
Zach


(Alan Tan) #2

Hmm this is odd and I’ve never seen this before. Try rebuilding from the console

cd /var/discourse
./launcher rebuild

(Zach Nedwich) #3

Thanks for the quick reply, I tried ./launcher rebuild app initially and it worked fine going from beta3 to beta4, but Docker Manager still thinks it’s out of date and/or in the process of upgrading?


(Zach Nedwich) #4

I just noticed the commit hash for docker_manager is different.

I ran

./launcher enter app
root@tarck-app:/var/www/discourse/plugins/docker_manager# git log --name-status HEAD^…HEAD
commit 61175ada7a1993647878c53320e9c6ffb1076dd2

So the repo is up to date but Discourse is showing an older hash (from Tuesday 18th Sep). I might try rebuild again and see what happens.


(Zach Nedwich) #5

Okay no luck with rebuilding the container again. Any ideas?


(Sam Saffron) #6

Hmmm what is your app.yml, are you pulling docker manager plugin from a branch?


(Zach Nedwich) #7
hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/davidtaylorhq/discourse-whos-online.git
          - git clone https://github.com/znedw/discourse-poster-location.git
          - git clone https://github.com/znedw/discourse-word-replace.git

master, I think?

root@tarck-app:/var/www/discourse/plugins/docker_manager# git status
On branch master
Your branch is up-to-date with 'origin/master'.
nothing to commit, working directory clean

(Sam Saffron) #8

Are you 100% sure rebuild worked properly and did not error out somewhere?


(Zach Nedwich) #9

As far as I remember the rebuild went fine, are the rebuild logs persisted or just written to stdout? I can probably run the rebuild again and paste the output somewhere?


#10

I had the exact same issue: even after manual rebuild, docker_manager was stuck in “Currently Upgrading” state and the “Reset Upgrade” button was throwing an exception.

I fixed the issue by running this:


(David Jameson) #11

I’m having exactly the same problem except that the process has gone part way through and then stopped. I realize it says, “This will take a while” but I started this yesterday.

== Seed from /var/www/discourse/db/fixtures/500_lounge_category.rb

== Seed from /var/www/discourse/db/fixtures/501_meta_category.rb

== Seed from /var/www/discourse/db/fixtures/502_staff_category.rb

== Seed from /var/www/discourse/db/fixtures/600_themes.rb

== Seed from /var/www/discourse/db/fixtures/990_settings.rb

== Seed from /var/www/discourse/db/fixtures/990_topics.rb

== Seed from /var/www/discourse/plugins/discourse-narrative-bot/db/fixtures/001_discobot.rb

== Seed from /var/www/discourse/plugins/discourse-narrative-bot/db/fixtures/002_badges.rb
*** Bundling assets. This will take a while *** 
$ RUBY_GC_MALLOC_LIMIT_MAX=20971520 RUBY_GC_OLDMALLOC_LIMIT_MAX=20971520 RUBY_GC_HEAP_GROWTH_MAX_SLOTS=50000 RUBY_GC_HEAP_OLDOBJECT_LIMIT_FACTOR=0.9  bundle exec rake assets:precompile
This monkey patch is no longer required.
Purging temp files
Bundling assets

(Zach Nedwich) #12

Thanks mate, this worked, can’t believe I didn’t see that post earlier. Upgraded docker_manager to the latest and all is well.