Featured Tiles Theme Component

I first want to say thank you for this amazing component. It has taken our forum up a few notches visually and a brilliant way to revive old threads without the need for staff to bump them to keep them fixable.

I have a question though and I may be missing a simple solution to this, but is it possible to remove the OPs avatar from the tile… Or preferably just remove the clickablility of the OPs avatar?

Thank you for this David, I am trying to get display-on-categories and scope-to-category working but I can only get the featured tiles to display on Latest and Categories home page, not the individual categories. Any idea what I’m doing wrong here, below are my settings. I have tried this with all other TC’s disabled and in safe mode with unofficial plugins disabled. I don’t see anything in the console or logs related to this.

Settings screenshot

Also, is there any way to add spacing between the images?

1 Like

IS there a wat to show 4 tiles in desktop and just 1 or 2 on mobile? It doesn’t look so good on it. Thanks!

Do you have editors-pick topics in every individual category?

You could do this using CSS, yes. Something like

.featured-tiles-container {
    gap: 1em;
}

This could also be done with CSS. To hide the 3rd, 4th and 5th square on mobile, you could do something like:

.mobile-view .featured-tiles-container > .featured-tile:nth-child(2) ~ .featured-tile {
    display: none;
}
2 Likes

Yes, I even tried setting it to only one category where the tag is used and it does not show up in that category. I tried different tags that are not part of tag groups, a category without restricted tags, but nothing seems to work. I also tried another site I have that is much simpler, doesn’t have TLP installed, etc. and it doesn’t work there either, even tried featuring a category rather than a tag, still doesn’t show up in any categories.

This works perfectly in firefox and chrome, but not safari. Any other ideas?

Also, a small feature request to have a title for the featured images, because how are people supposed to know what these images are? I know, I know, submit a PR, but trust me you wouldn’t want me to :grin: Just something like this:

Same here. I’m trying out the component on a new instance, so there’s not much else to disable. The featured tiles only show on Latest and Categories.

1 Like

Hey @david

In my tests for some existing topics the image is not appearing. I am running on latest test-passed.
What I tried so far:

  • put the image into the first line of the first post
  • renew HTML of the first post
  • removing and re-adding the featured tag
  • issue persists in theme preview as well

Any ideas?

I have this exact same issue. Were you able to fix it?

Any reason why this does not show on category pages even tho the option for it is ticked?