Font Awesome - "Flair url is invalid"


(Barbara Kerr) #1

I started out with one problem and now there are two: Each time I have tried today to add a Font Awesome icon, I kept getting the error message: “Flair url is invalid”.

Font-awesome-hands

I have tried multiple variations, but only the last one let me save it:

TAG i class= “fas fa-hands-helping” /TAG (as shown in image above)
“fas fa-hands-helping”
fas fa-hands-helping
fa fa-hands-helping
fa-hands-helping - saved

Font-awesome-hands-field-2
But once it was saved, 1) the icon didn’t show up and, 2) the background color of the flair disappeared from /groups when the system saved the font code.

I have enabled other flairs and icons before, but today I don’t understand why it’s not working.


(Robert McIntosh) #2

Discourse only includes Font Awesome 4.7 icons at this time and I believe you are trying to use a new FA 5.0 icon

We are about to upgrade from one to the other with Discourse Version 2.2 but this element is not released yet

We’re almost there with that particular element


(Barbara Kerr) #3

Do you have any idea when 2.2 will go live? Or, is there a way to find the 4.7 icon list that I can enable in the meantime?


(Danny Goodall) #4

I have struggled with this too, @BKerr, and whilst I knew Discourse didn’t support v5 glyphs, I didn’t realise it supported up to v4.7.

Armed with the v4.7 fact, I’ve found this sub-site.

https://fontawesome.com/v4.7.0/icons/

I haven’t checked it thoroughly but I can confirm that your hands-helping glyph isn’t there.


(Daniela) #6

https://fontawesome.com/v4.7.0/icon/handshake-o


(Barbara Kerr) #7

Excellent sleuthing for the icon @Dax. That worked like a charm!


(Joshua Rosenfeld) #8

To answer your other question, we don’t have an release date for 2.2, but that release date isn’t actually relevant as we release features to our customers (and those who self host) as we develop them. There’s no need to wait for the major version release.

To know when we’ve added it, keep an eye on Discourse Version 2.2 in the #releases category. You may also want to watch the #release-notes tag, so you’ll be emailed for each new minor release. FA 5 has been a frequent request, so I’m sure it’ll be called out in the release notes when it’s added.