Forum doesn't work as expected after latest upgrade (tests-passed)

Hi,

we have a forum under https://www.000webhost.com/forum/ and it shows JS error like below. Hence, latest/top/etc. functionality just does not work.

Anyone had this problem?

1 Like

Have you tried using safe-mode?

Yoururl.com/safe-mode

Yes, no joy. The same result.

Do you have anything unusual in your top menu site setting? If you can take a screenshot of it and paste it here, it would help.

Unusual is that no last topics are shown. The main page is almost empty. Everything else is as expected.

Right, but this may be due to something in your site’s configuration. I have tried several things locally, and tested on a few other sites (including here on meta), and can’t reproduce the issue. But if you show me what you have set on your top menu site setting, I can see if there is something unusual there that might be triggering the issue.

Would you mind to explain me what is top menu? Do you mean under admin mode or which one?

Yes, under admin > settings, enter “top menu” in the filter box.

Dunno what happened, but clearing that list and resetting back started working as expected… :slight_smile: Thank you for your help.

1 Like

No problem. @joffreyjaffeux fixed the source problem in this commit anyway: FIX: better fix for #ca84c06 (#6684) · discourse/discourse@7f089f0 · GitHub

1 Like