Forum shows Oops message


(Ankur) #1

My discourse forum is showing following Oops message. Please help to resolve.


(Joe) #2

Try safe-mode

You can get to safe mode by adding /safe-mode to the url like

your.site/safe-mode

You should see a bunch of options like:


(Ankur) #3

Still shows same message


(Ankur) #4

Actually, I had added a new plugin today - https://github.com/discourse/discourse-data-explorer.git
After that I rebuild app. it was showing *** system restart required *** when I login console. I turned OFF and ON again my digital ocean droplet.
Now forum is showing Oops message.


(Ankur) #5

I run rebuild app command but showing the error and rebuild stops.
./launcher rebuild app
Please help

I am using following plugins


(Joe) #6

Would love to help but this is over my head.

I’d say give it a go without any plugins just to rule that out.

No worries though, I’m pretty sure someone else will step right in and help.


(Ankur) #7

Still having the same error in ./launcher rebuild app
Anyone, please help
I have removed all plugins


(Mittineague) #8

What’s with the dollar sign$ at the end of the github repo paths that look like regex “ends” ?

Did you break the yml file when you edited it?


(Ankur) #9

Nothing that is the error during copy from SSH.
By the way, I have removed those all.


(Ankur) #10

I have done everything that I can.
container rebuild stops at --retry 3 --jobs 4
Forum is now showing Error 521 - Web server is down


(Tobias Eigen) #11

did you try to go back to the app.yml file you had before? whenever this sort of thing happens to me it tends to be because of a typo in changes I make in that file.


(Ankur) #12

No, I have checked that. I had only added a git clone url to the app.yml that is removed.


(Tobias Eigen) #13

ok - but you didn’t then add a stray letter or character elsewhere in the app.yml file? I have made this mistake myself and paid the price. now I always keep a backup of the file just in case. :slight_smile:


(Ankur) #14

Can you send me the content of app.yml file to check it out. I have edited it more than 10 times in past.


(Jay Pfaffman) #15

Like @tobiaseigen said, if you added or removed a space somewhere, that could be the problem.

It may also be the case that some plugin that used to work is now causing a problem. That flags plugin hasn’t been touched in a year.

If this is an emergency that you would like to throw money at you can pay me to fix it.


(Tobias Eigen) #16

this might help:


(Jay Pfaffman) #17

That’s a good idea. Another way to do that would be to

cd /var/discourse
cd containers
mv app.yml app-safety.yml
grep DISCOURSE app-safey.yml
cd ..
./discourse setup

(Ankur) #18

I think this all will remove data and install a new discourse :slightly_frowning_face:


(Jay Pfaffman) #19

No, it won’t.

It does assume that your data is stored in shared/standalone.


(Ankur) #20

Will it solve the problem?