Discourse forum wont load any pages whatsoever


My forum at the above URL in Discourse wont load whatsoever for me in my Chrome browser.

Not sure why. Things I’ve tried

  • Rebuilding Discourse
  • Restarting the server

Loads for me, I get the login page.

1 Like

Interesting… Is it possible to like clear Chrome cache or something to fix it?

I’m not sure, as I’m not sure what the issue is.

1 Like

Odd… Getting the same with the downloaded PWA

Hi Tyler,

Does it happen if you enable the safe mode?

1 Like

I cannot enable safe mode, it does not load

Also I noticed after clearing cache, that this problem only occurs upon logging in.

Did you try the tip?


This works! Now, how can I diagnose what went wrong?

I’d try the parts of safe mode individually:

  1. Plugins: /?safe_mode=no_plugins does it break?
  2. Themes: /?safe_mode=no_themes does it break?
  3. Unofficial Plugins: /?safe_mode=no_unofficial_plugins does it break?

If it breaks on themes and none of the other ones, it’s an unofficial plugin, conversely, if it breaks on unofficial Plugins and themes it’s an official plugin. Otherwise, it’s a theme bug.


Ok. I now know that it is an official plugin that is failing. I think I heard about it having some troubles recently :laughing:. If I rebuild Discourse does it rebuild all plugins with latest build?


If possible, can you check console logs? That should help pinpoint which plugin is failing.

Also yes, a rebuild should upgrade plugins, but knowing which one causes it would help too.


I cannot on school devices sorry, but I will try rebuilding the forum

I think when I rebuilt last, there was a memory issue happening with solved.

1 Like

Does the forum use docker? If so, you could try the admin upgrade page while in safe mode. (Thus avoiding the rebuild and downtime it mandates)


:laughing: Shoot! I didn’t think about that. I am already rebuilding it so I will just do that (plus the forum is already technically down)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.