Google Translate shows "blank" page


(Uwe Keim) #1

My goal is to send some English-speaking people a link to view the one or another topic on my forum, even if it is only auto-translated.

So I tried Google Translate on my German page:

+http://entwicklergate.de/t/php-laravel-mit-visual-studio-debuggen/159

It generates me this URL:

+http://translate.google.de/translate?hl=de&sl=de&tl=en&u=http%3A%2F%2Fentwicklergate.de%2Ft%2Fphp-laravel-mit-visual-studio-debuggen%2F159&sandbox=1

(I’ve added this + to prevent the preview here)

The “blank” page looks like this:

I’ve checked in different browser, with the same result.

I’ve also tried Bing Translator:

+http://www.microsofttranslator.com/bv.aspx?from=&to=en&a=http%3A%2F%2Fentwicklergate.de%2Ft%2Fphp-laravel-mit-visual-studio-debuggen%2F159

With a similar result:

My questions

  • Am I doing something wrong here?
  • Is this a known issue?
  • Any workaround?

(Jeff Atwood) #2

It is unlikely these sites can understand a JavaScript app like Discourse. There is a translation plugin here in the #plugin category.


(Mittineague) #3

From what I can see in the dev tools console it looks to me that the translate.google page has cross-site access issues with loading the iframe content.


(Uwe Keim) #4

Thanks, I’ve installed and configured this plug-in.

Currently, I see no translation icon as described in the above linked description, but maybe I have to wait some time…


(Anthony) #5

Turn it on in your site plugin settings :wink:


(Uwe Keim) #6

I did, of course. Probably my browser language will trigger the visibility of the icon.

Update I’ve set browser language to “en” (my forum is German). Still no icon visible (non-logged-in user).