Has anyone tried this RSS poster?

I was wondering if anyone has tried this. discourse-rss-poster.

I had an issue after installing it last night but now not sure if it wasnt just the adsense plugin causing the issues.


Heya Roland, I’m the author, I wrote this a while ago, but haven’t had the time recently to check that its been working with the latest versions, or test it enough to publicise it properly.

What’s the issue you’ve been having? The more detail the better. :wink:


Hey! Actually as soon as I rebuilt the app the screen went completely white. I thought it was your app then i removed it and it was still white screen. only access to safe mode and 404 page. It took a few hours and realized it was the adsense plugin causing it but I was so frustrated I never reinstalled it to try it again lol. I couldnt find any reviews or anything on here so I decided to ask beforehand. This is something I could really use and I had used on vbulletin for certain news threads.


Version discourse v1.7.0.beta 8 +15. The plugin works fine!!!

1 Like

And where you can find an explanation of these fields? Ato, I do not understand why they are needed.
Title RegExp Pattern
Title RegExp Options
Title RegExp Replacement
Body RegExp Pattern
Body RegExp Options
Body RegExp Replacement

They allow you to modify the title or body of the text with a regular expression.

If you’re familiar with JavaScript, it works akin to this:

title.replace(/pattern/options, replacement)

So, for instance, to put "RSS: " at the beginning of the titles of all topics created from a specific feed, one would do:

Title Pattern: ^
Title Replacement: RSS:

Or to replace every instance of “leo” with :lion_face: in the body of a post, one would do:

Body Pattern: leo
Body Options: g
Body Replacement :lion_face:

There’s some improvements which could be done in this area (like allowing multiple different regexps within the title/body), but this functionality satisfied the client who sponsored this plugin’s creation.

I noticed when I go to ad new rss it gets stuck with this mode at the bottom and nothing is entered yet,

All manner of things could be causing this to happen, could you send me (either by reply, or PM if you’d prefer) your logs around the time this happens?

sent you a PM with the logs

Does anyone know how to fix this?

You need to fill in the Interval (minutes) field with a number - this will be how often the feed is checked for updates.

I did that. Set at 5, tried again at 20, tried at 30. Doesnt change anything.

There was a small issue causing the value of the interval field to always be empty - I’ve pushed a fix to the plugin’s repository, so a rebuild should allow you to add new feeds.


Thanks. now it lets me save it.

Hi Leo thanks for this plugin.

Would it be possible to add tagging to the feeds?
This would prevent the need to create lots of categories for regional news etc

Also I’m a bit lost on the regex. I’m looking to add the image from the BBC feeds.

Hi Leo, I’m still getting this issue. The plugin was added yesterday.
It added the first feed but stalls on additional feeds as described above.

I’ll try and find some time to take a look at it this weekend


I checked it out again with the update. Cant save anything again.

And who uses this plugin? Does it work for you? Ato at me with it discourse does not start (