I can't log in with SSO


(Dmitriy Gryn) #1

Forum has sso. And only one button “Log in”, i tried to add “Sign in” button by adding to CSS

.login-button::after {
    content: " | Sign up";
}

after testing, i delete this and save. But now i can`t log in to forum, and when press “log in” i have popup

I need just redirect to mother site(SSO)

Help please! Thanks


(Simon Cossar) #2

You need to bypass SSO and fix the problem. If you have access to your server run this to disable SSO:

cd /var/discourse
./launcher enter app
rails c
SiteSetting.enable_sso=false
exit
exit

If you can’t access the server, you can use the /users/admin-login route to bypass SSO. Go to
http://forum.example.com/users/admin-login, enter your email address, and then follow the instructions in the email you receive.


(Dmitriy Gryn) #3

Great. Thanks
I don’t have any idea what the problem could be. .
I think css can’t break
Maybe some settings in Login tab.

But sso redirect break after that css selector


(Simon Cossar) #4

I’m not sure what the problem with that is. The easiest way to set the text for the login button is to go to Admin/Customize/Text Content and search for ’ js.log_in’. You can edit the text to say ‘Log In | Sign Up’.


(Dmitriy Gryn) #5

I’m sorry for disturbing you, but it`s matter of life and death.

By steps

  1. I added and saved
    .login-button::after {
    content: " | Sign up";
    }

  2. saved and saw that “log in” button isn`t redirect me to sso site but show me popup login

3.I deleted that selector and saved. But ‘Log In’ button didn`t return old action, it just show me popup.

How sso url and button are releted? Can i change relation?

Also i have “sign up” button that redirect me to “sign up” page of sso site, it still work correct. I can`t undestand how css can broken redirect to sso action…

P.S Little note, now in fact i am having little icon with person, but didnt have it before first step.

.fa-user:before {
    content: "";
}

Sorry and Thanks


(Simon Cossar) #6

Make sure that ‘enable sso’ is checked.


(Dmitriy Gryn) #7

Many thanks for the help. You saved me.

SiteSetting.enable_sso = true - fixed up the isssue

One more questions.
I have ‘sign up’ and ‘log in’ buttons. But ‘Sign In’ appears after click on .d-header clearfix
How to make “Sign Up” appear always if current_user == nil (anonymous) ?
Maybe change CSS, JS or some settings ?

I read some topics on meta.discourse was said that it doesn’t make sense when you are using SSO. But we need that button.

This is the last question I promise. Thanks


(system) #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.