I can't uncheck the two checkboxes in the embedding setting: Admin-> Customise -> Embedding

I am trying to uncheck the two checkboxes in the embedding settings to disable the truncate and unlist features when generating posts from my site in which discourse is embedded. It seems not to work as every time I click save and then fresh the page, these two checkboxes are checked again.

I investigated a little myself by checking the developer tool. Found that every time I uncheck the checkboxes and click save, this API is called https://site.com/admin/customize/embedding. However, in the payload, these two ebed_truncate and ebed_unlisted attributes are always true no matter whether the checkboxes are checked or unchecked.

  • I’m using 3.1.0.beta5 and the official docker installation guides.
  • Chrome 114.0.5735.199 on Windows
  • Tested on Firefox 114.0.2, still not working

Could it be something wrong on the front end side? Any advice and direction would be appreciated!

1 Like

Hey Wang Xing!

Thank you for reporting!

I can repro the issue, it looks very much like a bug, so moving it to the proper category. :slight_smile:

1 Like

Hello, I upgraded to 3.1.0.beta6 and the issue remains. Do we have a plan to fix this bug already?

Just to provide a small update - this issue has been assigned to an engineer to investigate. Hopefully we’ll be able to have more concrete news soon. :crossed_fingers: :slight_smile:


This has been fixed and merged here FIX: Embedding checkbox bug by jdmartinez1062 · Pull Request #22672 · discourse/discourse · GitHub. Let us know if you encounter any issues


Nice work! I updated my site and the checkboxes work normally now.

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.