How to disable the 'embed_truncate' setting


(Simon Cossar) #1

Is there a way to deselect the embed_truncate setting? The problem is that it’s showing even when the full post has been sent.


(Robin Ward) #2

You can disable it in the admin section at any time. However, that won’t update posts that were already imported. The only solution to that is to reimport them via the rails console.


(Simon Cossar) #3

Where is the setting for it?


(Robin Ward) #4

It’s in /admin/customize/embedding with the other embedding options.


(Simon Cossar) #5

I haven’t added any hosts to my site - I’m publishing posts with the wp-discourse plugin - but am still getting this:

I can see how this function could be useful for when a post excerpt is published through the wp-discourse plugin, but could there be a setting added to admin/site_settings/category/posting to make it possible to disable it for sites that are using the wp-discourse plugin to publish full posts to Discourse?


(Robin Ward) #6

Aha! I didn’t realize that setting was used by wp-discourse without setting up embedding customizations. I’ve un-hidden the setting and it should be alterable via site settings now. (It’s still editable on the embedding tab too.)


(Robin Ward) #7