I want to keep PostgreSQL database on separate server [standard docker install]

I tried everything but I always get this error. I tried the methods below but I get the same error every time.


./launcher rebuild app
x86_64 arch detected.
Ensuring launcher is up to date
Fetching origin
Launcher is up-to-date
Stopping old container
+ /usr/bin/docker stop -t 60 app
(<unknown>): did not find expected key while parsing a block mapping at line 40 column 3 -e LANG=en_US.UTF-8
YAML syntax error. Please check your containers/*.yml config files.

Is it not working because it is a standard installation? thank you for helping.

That means that you made a mistake while editing the app.yml file. You need to edit and fix the mistake that is around the line 40.


Thanks for your interest but I’m not making mistakes, I’ve tried every possible way. It gives the error only when I add these codes. It doesn’t give an error when I remove it. and I remove the code in the line where it gives an error, interestingly it gives the same error again. in the error code LANG=en_US.UTF-8

     DISCOURSE_DB_HOST: localhost
    DISCOURSE_DB_NAME: "sssss"

Am I adding the codes in the wrong place? Shouldn’t it be added under env:?

  • my new server database postgresql 14

Thanks for help

YAML is white-space indented and it’s very easy to make mistakes like this if you aren’t familiar with it and very careful.

Every one of those must be under the env section and following the same identation level as other similar keys. You can leverage tools like http://www.yamllint.com/ to validate your configuration.


You are amazing, I was so busy because of an interesting gap :slight_smile: I owe you…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.