Issue with creating admin account for first time


This is my current configuration and I cannot create the first admin account because its not sending the activation email. I have used SMTP with my provider and it works, the issue is with discourse I have tried the same credentials with thunderbird and it worked.

I have tried my doctor also as this topic suggests.
These are the results

Hi,

Spacemail isn’t recommended as a mailing service for Discourse as it’s recommended for personal usage. It is very likely that they are going to block mass emails and/or it just simply won’t work. I use it too.

Try using Mailjet, combined with Spacemail, and simply use Mailjet for Discourse-emailing and leave Spacemail for personal use. You can have more than one mailing provider in DNS records.

Edit:
You can bypass it as @pangbo has suggested but it’s not a long-term solution.

1 Like

You can create an admin using command line, thereby bypassing the email verification.

./launcher enter app
rake admin:create
2 Likes

for port 465, TLS must be true.

This does work but my primary problem is that users cannot register because of that problem.

I have tried, it doesn’t work.

1 Like

Spacemail isn’t recommended as an email provider as you most likely have their personal business account package which isn’t intended as a sending service. View my reply and use another provider such as Mailjet or Mailgun which you can use on the side for Discourse, it’s free.

Most of the “supported” hosting is extraordinarily overpriced and has very strict limits. And my provider doesn’t have any package they give SMTP access to all accounts.

As said, I use Spacemail - it is not for commercial sending, it’s not an email provider, it’s a personal business email service.

See Troubleshoot email on a new Discourse install.

A common problem is that the notification email is set to something that your smtp service won’t send from. It’s likely sending from noreply@your.forum and you likely need to change it to your email address.

But in the other topic you created for this problem you say

So your vm is blocking outgoing access to that port. Many services support port 2525 for this reason. You might be able to open a ticket and get them to unblock it.

1 Like