Keep losing 'edit' in Data Explorer

I’m working on a new Data Explorer query.

Every time I Save Changes and Run, I’m kicked out of Edit mode & have to re-select it:


I’ve been finding this a difficult new quirk to get used to. :slightly_smiling_face: I’m not sure if it’s intentional/necessary based on some changes that were made, but I’ll see what I can find out. :+1:


Besides being annoying, this means I can’t undo :frowning:


I agree this behavior is a little odd. I will get this fixed up :slight_smile:


This is fixed today. Thanks so much!

1 Like

Are you sure? I have not made the changes yet :slight_smile:

1 Like

Doh! I’m wrong. I opened a query, went into Edit mode & then ran it just to see. I retained edit, but now that I’ve actually started… editing I’m back to being kicked out of edit mode. :frowning:

(And I posted this first in the wrong thread, so now I can’t paste it in the right thread without additional text (I hope this works) because it’s “too similar to what [I] recently posted”)


*sigh* I’m working on editing updating some reports right now and

  1. edit
  2. run
  3. review
  4. click ‘edit’
  5. resize the editing window
  6. goto 1

is getting really painful :sadpanda:

1 Like

Good news, I have finished a fix today :slight_smile:

It should be out in the next couple of hours.

1 Like

The fixed has been merged and I have deployed your site to pick up the change. Please let me know if something looks off.



My previous topic on this… topic got locked awful fast… :smiley:

Was there some regression? This was working for a while (my prev thread was already locked when I came back to say “THANK YOU!!!”) but now I’m getting kicked out again. :frowning:

1 Like

@ganncamp are you still experiencing issues with editing in DE? If so, would you be able to explain your circumstances? It seems to be working as expected on the latest version of the plugin for me.

I was working yesterday in DE. I had a few different windows open.

After you posted that you’d fixed it, I tried & it of course failed. Hard refresh and it worked.

Came back today and spent my morning doing other things. Finally after lunch I was able to turn back to my reports. I’m not sure whether this is related to hitting SQL errors (“must group by x…”).

I think this was working fine this afternoon at first, & then I made my first mistake & got kicked out.

“Huh. I didn’t refresh this window” I thought, and did so. Multiple times. But I keep getting kicked out again.

Just now (trying to confirm my theory)

  • hard refresh
  • Edit
  • change
  • run
  • mistake [retain edit]
  • correct mistake
  • run [lose edit]

Hmmm, edit state seems to be maintained through this case for me

I wish it did for me. A SQL error seems to put my window in a bad state…?

Not on my local instance… i can have a sql error and maintain edit state. I also tested with an empty param and changing the window size. In all cases it works as expected.

So… Uhm… How do we figure out what’s different for me?

It seems like your site is not on the most recent version of the plugin. I will update that for you and we will be good to go.

edit: @ganncamp tested on your forum, it is working as expected now :slight_smile: