Logo url won't reset due to Ghostery


(Philip Colmer) #1

The URL that “logo url” is pointing to is broken. We’ve tried the following to point the logo URL at a “working” location but Discourse keeps reverting back to the broken URL.

Option 1: reset
Option 2: copy logo small url and paste into logo url

In both cases, the UI appears to show that the change has occurred. However, refreshing the Settings page shows that the old (broken) URL is still there.

This is with the latest version (1.8.7) of Discourse but it was happening on the previous release (1.8.6) as well.

What can I do to fix this? The site doesn’t look good with the broken logo :frowning:

Thanks.


(Joshua Rosenfeld) #2

1.8.7 is not the latest version of Discourse, 1.9.0.beta10 is. I cannot reproduce this on the latest version.


(Mittineague) #3

If you mean the stable branch, I know serious fixes are backported (security, crash edge cases etc.) but I can’t opine where this falls

Note the

We will only backport urgent fixes between releases (on a case by case basis).

If you are certain this isn’t because of a bad config somewhere, maybe upgrading to tests-passed would be a good option if you’re wary of beta?

EDIT - misinformation struck


(Philip Colmer) #4

If you are certain this isn’t because of a bad config somewhere, maybe upgrading to tests-passed would be a good option if you’re wary of beta?

My interpretation of the page you’ve linked to is that tests-passed is more bleeding edge than beta.

If the consensus is that this has been fixed in a version between 1.8.7 and 1.9.0 then I will be patient. It isn’t ideal having the logo broken but, from my perspective, it is preferable to running our production site on anything other than the stable branch.

Thanks, @jomaxro, for confirming you can’t reproduce it on the latest version.


(Jeff Atwood) #5

Doubtful this is a bug in 1.8.7 or @michaeld would have let us know.


(Philip Colmer) #6

If it isn’t a bug, are there any suggestions on what steps I can take to either get the setting change to stick or to determine why it isn’t sticking?

Thanks.


(Joshua Rosenfeld) #7

It’s not going to be so easy for us to test this as our sites are running tests-passed, not stable. I’d suggest reaching out to the team at DiscourseHosting to see if they can replicate it on another stable branch site.


(Michael - DiscourseHosting.com) #8

@jomaxro @codinghorror Not all people who are on Discourse stable are our customers… this is not about a forum hosted with us.


(Jeff Atwood) #9

Right but my point is, if there was a big huge bug in stable you guys would let us know, and we would fix it, yes?


(Michael - DiscourseHosting.com) #10

Correct :slight_smile:


(Philip Colmer) #11

Now upgraded to 1.8.8 and the problem is still there.

Are there any manual steps I can take to correct this rather than working through the GUI?

Or any logs I can look at to see if an error is being reported?


(Michael - DiscourseHosting.com) #12

Only cause I can think of is that the URL contains something that is blocked by an ad blocker on your system.

Can you try to change it on a different system? Or what happens if you replace it with a totally different URL? Just find some image on the internet and use that URL, just as an experiment? Does it break as well? Is this a URL to an uploaded image? Or does it point elsewhere?


(Philip Colmer) #13

I’ve tried saving the reset option (so that’s /images/d-logo-sketch.png) and I’ve tried copy/pasting the “logo small url” value.

I’m wondering if there is anything being caused by the fact that the current URL is broken? Is Discourse doing any sort of check on the current value that is causing saving the new value to fail?


(Michael - DiscourseHosting.com) #14

Yes, you said that you did all that in the first post.
How about trying the suggestions I gave you? :slight_smile:


(Jay Pfaffman) #15

Can you share the URL of your site?


(Philip Colmer) #16

OK - problem solved and Michael nailed it.

I have the Ghostery browser extension installed on my machine and that was (somehow) preventing the URL from being changed. Disabling Ghostery allows the URL to be changed.

Very strange.


(Joshua Rosenfeld) #17

This topic was automatically closed after 10 hours. New replies are no longer allowed.