Lot of smpt problems, cant send mails via different servers


i have set up a new discourse instance (on Ubuntu 20.04 on the official way) and can’t get the mail settings to run. This is not my first discourse installation, I never had problems before.

I started with a mailserver at the german provider strato.de. From nextcloud and wordpress I can connect and send mails without problems. discourse-doctor reported: 538 5.7.11 Authentication not possible, please use a connection with SSL/TLS encryption. I have tried DISCOURSE_SMTP_ENABLE_START_TLS: true and switched ports 25, 476 and 587 also.

After that I tried another mail server, same problems…

Finally I used a mail server that works without problems in a second discourse instance that I run (its not updated to the latest version, maybe thats the point). I used exactly the same paramters. Unfortunately no connection here either.

With swake I was able to access every mailserver from the same system and could send mails.

Is there a bug in the current version or what am I doing wrong?

thx for help!

Did you ./launcher rebuild app or ./launcher destroy app;./launcher start app after making the changes before trying again?

1 Like

I did ./launcher rebuild app, thought this is the safest way…

1 Like

Somebody knows a way to install an older version on a clean system?