Mobile app logged out of meta?

Found myself logged out of meta from the Discourse mobile app today. Tried logging in and got “Incorrect username, email or password”

I tried a password reset via email. I was logged back into the site (as a side-effect of the password change process). However, I still can’t log in with the new password I’ve chosen.

Edit: after a second password reset, the password seems to have changed successfully, and I can now log in.

The problem could be at this end, but wanted to flag it in case anyone else had seen similar today?

There are known weirdnesses with cookies specific to the app, all OS bugs. @sam can point you in a topic direction.

Yeah this is frustrating and has popped up multiple times in the last week, including happening to me right now.

For some reason Safari View Controller, “forgets” cookies under certain conditions. Redirects tend to cause this and other random apple bugs.

I plan to make it so you can “auth” the app direct from Safari, then it will be trivial to deal with the situations when this annoyance happens.


Thanks @sam.

Worryingly it just happened to me again - that makes several instances in the last couple of days. Odd, as it had been fine for months beforehand.

Also, only seems to be meta that I’m logged out of. My sites have been okay so far.

Just as an additional data point - This is still happening on meta, and just happened again to me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.