Multi site smtp email problem


(Aashish Gangwani) #1

Hi,
So I read the multi site configuration thread by sam and this is the app.yml

The sites seem to be running ok but it wont send actiavation emails for some reason

Here are the recent logs:

I don’t see any problem in app.yml and all the ./launcher bootstrap app logs went with no errors so I don’t understand why the discourse won’t send any emails I also followed solutions in the “troubleshooting email” thread by coding horror but the problem still persists.

Even the logs dont tell anything here like “mail not sent authentication error” it should show something like this, there is no mention of success or failure of mail in production.log at all I have also checked redis, stdout and nginx logs but no mention of mail even over there.

I also tried sending an email via telnet and SMTPTestUtility.exe by logging into docker app by executing “./launcher enter app” and it sent the email successfully so the problem isn’t in docker but discourse app.

Before considering this as duplicate please note that I have been trying out many solutions since 4 days now and after trying every solution and failing have I decided to post here.


(Aashish Gangwani) #2

I solved this just now. It was because mailjet needs to verify every “from email” by sending activation email to the email. So I authenticated my domain’s email address and I can send it now.


(system) #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.