Muted categories appear in Categories page

I muted two categories and it still appear on top of the categories page (since it have recent activity). Shouldn’t it be hidden or at the bottom? It’s more annoying when I use categories as home page. And “categories with featured topics” option even showing me muted category’s topics too. Also is it better to order categories by notification_level and then activity.

6 Likes

Yes we should fix this in some manner cc @sam.

4 Likes

May I create PR to exclude muted categories from categories.json?

Of course, but don’t “exclude” them, mark then as “muted” instead.

In categories.json it already have notification_level=0 property. If we excluded it will not display in all categories listing locations (like categories page, composer dropdown, filter dropdown, etc.,). Or we have to manually hide it or order it to the bottom position in all locations.

1 Like

You can’t remove categories from categories.json, otherwise they’ll never appear anywhere if you mute them.

I would start with ensuring we respect the notification_level=0 for the /categories page first.
Then I would deal with the dropdowns and such.

1 Like

I thought it shouldn’t appear anywhere except user’s preferences page setting muted categories. If it will affect site’s functionality let’s do manually.

categories.json” is the source of truth for categories. So if you remove them, they’ll never appear anywhere :wink:

4 Likes

Please can you fix it, we’ve have a business plan with this behavior since February 2020

This is by design, if you wish to suppress them on the categories pleas use a theme component.

3 Likes

You can use this theme component to suppress the categories.

7 Likes