Not finding the Wiki select in the wrench menu

I’m following the How to Create a Wiki post, but there is no wiki option in my wrench menu. I can’t seem to find among the topics after 2017 where anyone else has had this problem. Can someone help, please? Thanks.

Expected behavior:

  • Option to convert post type to wiki is available.

Actual behavior:

  • No such option is found in the wrench pop-up menu.

What is your trust level and what is Admin - Settings - Trust Levels - min trust to allow self wiki set at?

I am trust level 4 and Admin; the trust level for Wiki is set for level 1.

There are two wrench buttons, you need the one directly below the start post, hidden behind the dots, not the one at the end of the topic.


Tried it - your screenshot looks different than mine. The lower wrench opens up the same menu as the top-right wrench. The 3 dots have only an “edit” pencil under them.

I edited one of my categories and selected “make all topics wiki by default”. That worked for that category. But there still is no way to wiki-enable one topic or to un-wiki a topic in a default Wiki-enabled category. Is there a setting I need to change?

Can you check your post menu and post menu hidden items site settings? Both of those settings should have an entry for admin. If that entry is removed, the admin wrench icon will not be available in the menu for admin users. The default values of those settings looks like this:

1 Like

And there it is!
I customized the post menu setting when I was setting up the platform. It’s my “Fire-ready-aim” approach to programming. :slightly_smiling_face:

Thank you for solving it - and for your patience!


I’m glad that worked. I’m not sure why Discourse allows the admin entry to be removed from the post menu. At the very least, some kind of warning should be given when it’s removed.

1 Like