Pending posts notification for moderators

I can’t find a way to notify the moderators that pending messages are waiting. Please advise.

I have searched the form and I can’t find the answer. One guy said this feature was added “two weeks ago”, but I can’t find it.

2 Likes

Messages waiting to be approved should show up in the Review queue.

Do you have the boxes ticked for it in the category settings?

3 Likes

I’m sorry for being unclear. Specifically, I want to email the moderators each time a new post or reply is waiting for approval.

Sometimes I go hours and hours before checking the board and finding old messages waiting to be approved.

2 Likes

There’s a ‘notify about queued posts after’ setting that may be useful?

That will send a notification out, and should send an email soon after (depending on your email preferences)

Update: I set this on my test site for 1 hour. I did indeed get a notification sent to my test moderator for the queued posts, but no email was sent out (both email settings were set to ‘Always’). I’ll have another look.

I did get an email for this one after I set the Notifications to ‘Watching’ as @osioke suggested. :+1:


Edit: After a little rummage around, I also found this one for flags:

Update #2 I then set this one to ‘1’, and my test moderator got a private message after the hour saying there were items to review. This one did send an email. :+1:

2 Likes

To add to what @JammyDodger said, my colleague @Dax just reminded me that moderators will be notified/emailed only if they set the moderators inbox to “Watching”.

3 Likes

I’ve tripped over myself a bit with this. :slightly_smiling_face:

I did not get the email from the first test (notify about queued posts after) because the Moderator inbox default is ‘Tracking’ and not ‘Watching’. You can change this default by going to /g/moderators/manage/interaction.

The emails I received were indeed from the second test (notify about flags after), as those reminders were sent as PMs.

Both seemed to work for ‘approved posts’ though.

I’ll go back and edit the other post (again). :+1:

2 Likes

I would have never figured this out by myself – thanks!

I put a fraction in the notify field (0.25). Let you know if it works.

1 Like

I tried that too, and it does not. :slightly_smiling_face: If you check back again now, it will have reverted to 0.

1 Like

Doesn’t setting the moderator inbox to watching not resolve the issue for you?

My forum only has 6 members, so I am waiting on somebody to post… Let you know.

1 Like

2 posts were split to a new topic: How to change a group notification setting on mobile