Request: Allow easier customization of "outdated browser" message


(Zane Beckman) #1

Continuing the discussion from Unable to change browser update message string:

I’m suggesting that this text should be customizable from /admin/site_contents.

Currently, it says the following:

Unfortunately, your browser is too old to work on this Discourse forum. Please upgrade your browser.

It can be adjusted by editing client.en.yml as described above. However, I think it would be beneficial for it to be adjustable from /admin/site_contents.


(Jeff Atwood) #2

Customized to what exactly? What else could be said there?


(Zane Beckman) #3

The link could point to a different site. i.e. whatbrowser.org

The first part could be adjusted to include the community name.


(Martis Genus) #4

In general it would be great to easily overwrite particular variables in client.en.yml. Can this be done in a plugin?


(Kane York) #5

Yes - include a locale file in the plugin overriding the exact strings, and a plugin.rb with just headers.


Overriding strings in server.xx.yml?
(Jeff Atwood) #6

OK in the meantime I shortened it slightly to

Unfortunately, your browser is too old to work on this site. Please upgrade your browser.