Reverting version after problematic update

How I can revert?

Thanks

Normally it is not recommended in my opinion, but the steps would be the following:

In your app.yml, in the version tag (Uncomment the line), replace test-passed with “v2.9.0.beta9” (Corresponds to the tag on GitHub), and rebuild

Although you will have to switch back to test-passed sooner or later

1 Like

Can I use the same steps to downgrade to the “Stable” version?

Theoretically, yes, but certainly that change could lead to a broken site.

I appreciate your help,

i tried but it didn’t work

I think I have to wait for an update to solve the BUG

Unfortunately the site without css is so bad user experience

There’s nothing theoretical here. Migrations aren’t reversible.

Downgrades without a backup are never an option.

2 Likes

i have old backup.

So can i downgrades by edit app.yml version to “Stable v2.8.9 ”. and rebuild app ?

is this possible ?

To avoid any database issues you will need to pinpoint the exact version in the backup and build a fresh instance on that, then restore your database.

The issue here is that you upgraded a production site without testing it first, if your site is important then you need to reduce the risk of these updates by first testing it on a representative staging copy.

2 Likes

My old backup for “Discourse 2.8.9”
How to build a fresh instance for 2.8.9?

Were you previously on tests-passed or beta?

If you were on tests-passed then you need to do as I said above and check your backup for the precise version it was taken at.

2 Likes

backup for discourse 2.8.9 - previously on tests-passed .

can you tell me the steps to build a fresh instance for this backup.

How can install fresh discourse 2.8.9 so i can import my backup latter without risk?

Thanks.

If you were on tests-passed then a fresh 2.8 beta 9 install work won’t work for you, which is why you can’t use v2.9.0.beta9 as suggested by someone else above. As the name indicates, tests-passed is the latest version of merged changes which has passed the requisite suite of tests.

You’re going to need to pin the exact version of Discourse in your app.yml by inspecting your backup file.

If the plugins you use have been updated since the build in your backup then you may also need to pin those versions in the plugin section of your app.yml.

Not entirely. Any higher version will do. So if your backup was from stable then you can either install stable or check out a specific commit (7647cf6a22aa7f9454123b24262ca04290b4d774 for 2.9.0 beta 9)

Right, but it’s from test-passed, not b9 or stable.

It’s an update which broke compatibility, hence aiming for a known-good configuration.

1 Like

I think he means “my backup is from 2.8.9 and I was previously on tests-passed”
So if he restores the backup then anything >= 2.8.9 will do.