Review queue bug?

On up-to-date tests-passed.

I tried to approve a new user today which popped up as notification needing approval, but when I navigated to the review queue I was presented with an older approval I’d already actioned and upon trying to delete that user again (it was a spammer) it appears I’d deleted the new user. The record I’d been shown visually was not the same record the system then deleted. Most odd!

So tried this again (after the user kindly re-applied) and the same issue happened, but as workaround I looked into Admin -> Users -> New and approved the user’s record manually without using the review queue UX

Apologies for lack of extra information but just suggest this might be one to look out for, very confusing and I ended up blocking the wrong user …

I’ve read this two times and I still can’t follow. What are the reproduction steps?


Sorry Jeff, far from a quality bug report.


  • Ensure all new logons must be approved
  • Get a new user to request access
  • Delete & Block this account
  • Get another new user to request access
  • Enter review queue when notification appears
  • You see old access request (not the new one)
  • Deleting and blocking will however delete and block the new user access request, not the one erroneously displayed.

NB I’ve been busy with other things and not had time to reproduce this again … it’s possible it was just a passing glitch, so just a heads up really: if anyone else experiences the same it might be worth further investigation.