Should direct messages be approved?

In our newly moderated forum, I just got a moderated post which I think is a reply to a private message I sent a user.

Should PM’s be exempt from moderation?

1 Like

I thought @eviltrout changed something around this recently. I can’t remember, though. New users can’t send PMs at all, but they can reply to any PMs they are sent.

ok, in this case no one without TL3 can post w/o it being moderated.

no one is TL3 but for staff.

The user was replying to a direct message I sent him.

I was on Beta 7 +35

Update - my reply to the user was also moderated.

@codinghorror does that count as a bug? :stuck_out_tongue_winking_eye:

I think you are on an old version of Discourse and should update… I am often unclear if you are talking about your hosted instance with us, or something else. in this case based on the additional version information you provided, this was fixed a while ago.

In the interests of wasting less of your time, and less of ours, I suggest you indicate whether you are referring to your hosted instance or something else on an unknown (to me) version.

I alluded to this in my first rely when I said “I think eviltrout fixed something around this recently”. That is your cue to update to latest :wink:

1 Like

Agreed, I should be up to date, but because many of the changes I need can’t be done in /admin, I’ll have to keep self-hosting for now.

That said, I’ve updated to v1.3.0.beta9-dirty and have repro.

Because I don’t know the best way to enable the feature, I’ve done this:

I suspect it’s the approve post count overriding the fact that I’m admin/moderator

Fair enough, @eviltrout can you have a look?

Also - it was only when replying to the private message I started. I didn’t run into this when creating the PM initially.

Hmmm, is the “approve post count” above the recent “sanity” limits ?
i.e. no more 999999999999999999999

It is nowhere close to the maximum for an integer. Setting a value high is valid.

1 Like

Looks like replies to PMs were handled slightly differently than creating PMs. I’ve fixed it: