Site settings search broken


(Jay Pfaffman) #1

I’m running Discourse 1.7.0.beta6. All searches of site settings return no results. I don’t think this is related to this or this.

I recently changed the hostname. Could that have broken it? (It seems like it has worked since then, but I could be wrong.)

Is there some rake task that rebuilds that search index or something?


(Joshua Rosenfeld) #2

I noticed this as well - but I assumed it was an issue with my specific instance, since we’re subfolder.


(Jeff Atwood) #3

Can we repro this @eviltrout?


(Jay Pfaffman) #4

Well, I can’t. I just rebuilt and it’s fine now.

Perhaps my last rebuild was just before this:


(Robin Ward) #5

There was a regression with my deprecation work that broke this. @zogstrip let me know shortly after I merged it and I fixed it, but if people updated to tests-passed in that timeframe it was broken.


(Joshua Rosenfeld) #6

Is a full ./launcher app rebuild needed, or a simple /admin/upgrade sufficiant?


(Robin Ward) #7

Just a regular admin/upgrade.


(Jeff Atwood) #8