Some plugins not working after upgrade


(Kovah) #1

I recently updated Discourse from 1.4.3 to 1.4.5 and the tagging plugin stopped working. I disabled the plugin.

Now I wanted to try the Feature Voting plugin. Unfortunately I didn’t know it only works with Discourse 1.5 beta. I also disabled the plugin after errors showed up.

Now I updated my Discourse instance from 1.4.7 to 1.5.0.beta13b and re-enabled the two plugins.

The problem: both plugins show up in the plugin settings and I can configure them but it seems the plugins are only loaded for the admin section.
Whenever I want to add tags to a topic the tag bar does not show up and I also can’t enable the feature voting for categories because the option is simply missing. It’s like the plugins are not enabled.

Is there something like a plugin cache that got corrupted while trying both plugins with 1.4.5? Or any other cache that may lead to this weird behaviour?


Steps I already tried:

  • Rebuilding the app (maybe 10 times or more with different settings in the app.yaml)
  • Deleting the plugin directories from /var/www/discourse/plugins and rebuilding the app
  • Turning the plugins off and on again in the settings

Other activated plugins:

  • discourse/discourse-solved
  • ligthyear/discourse-plugin-checklist
  • Jake-Shadle/discourse_jira

(cpradio) #2

Disable that one and replace it with

The one form lightyear won’t work on 1.5.0


(cpradio) #3

Also, I’m 92% certain that the checklist plugin you have enabled is why you are running into issues with Feature Voting and the Tagging plugins. There were similar reports in other topics and once the changed to the rewritten checklist plugin I created for 1.5.0+, it solved their issues.


(Kovah) #4

Thanks for the hint, I will try it as soon as possible.

Edit: yes, it really worked! Thank you for that!