Some posts land as embedded replies, not answers

What the title says, and we can’t find the pattern. I thought this was about Email replies land as embedded replies, not answers but we are seeing this problem with replies posted on the web, not via email.

See “3 Replies” at the top post here.

This bug is a blocker to use this plugin in a serious / production setup (right now we are just testing with ice cream flavors). :slight_smile:

3 Likes

I have been trying to repro this but have had no success so far. Is there any more detail you can give for the exact steps they took for it to happen? If you created another post-voting topic, do you think you could get them to do it again?

3 Likes

Hello, I tried to reproduce this issue several ways and for now I only can if I quote from the OP in my reply. But this will show the post too not just the embedded reply so probably not this is happened on your. I will keep trying to see if I can reproduce it in another way. :slightly_smiling_face:

2 Likes

Beats me as well. :person_shrugging:

We ran another test and so far there haven’t been any problems, although less people participated:

Can it be a problem caused when two users are doing something concurrently with the topic? I don’t have any specific idea, but it could be a reason why testing with one person or in a quieter topic doesn’t bring any errors, while maybe it happens when you have more than than one user interacting with the topic.

I think I can repro this issue. :slightly_smiling_face:

Repro:

When the composer is open you can change the recipient by clicking the specific post reply button.
This is the case in post voting topic OP because the OP has an Answer button.

  1. Open composer to create an answer
  2. Click the OP Answer button
  3. Post your answer and it will be posted as correct voteable post (vote options not working) and the OP’s embedded replies since these are connected but after reload the page only the embedded reply left.

It is pretty hard to imagine this happened but there is a really easy repro when you open composer by double clicking the OP Answer button.

On the video I show both method.
1. I open composer with the reply button then click the Answer button in OP.
2. I open composer with double click the OP Answer button.

Actually these two method has same result but I think probably the second one happened on your site. :slightly_smiling_face:

6 Likes

Wow @dodesz, (or should I call you Sherlock :slight_smile: ). This is impressive! Thank you so much.

2 Likes

That is brilliant. :slight_smile:

I can now repro this on my test site using this method. :+1:

4 Likes

Actually, it is a bug in the core. We didn’t see it before since it doesn’t affect anything without the post-voting plugin.

2 Likes

Like in the above screenshot, this same bug happening in the core itself without enabling post voting plugin.

1 Like