Third party plugin causes rebuild to fail

I tried rebuilding my website co it crashed about 4 hours ago… I have no idea how to fix this rebuilding issue. I’ve tried all the fixes on this forum (the ones that I could understand). But none of them worked. Can you guys help me out?
The Error:

Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 11252 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"db_migrate", "cmd"=>["su discourse -c 'bundle exec rake db:migrate'"]}
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages,there may be more than one

It asks me to scroll up and check… This is the only error that I could find after scrolling up.

> I, [2019-05-02T16:18:15.465377 #14]  INFO -- : > cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate'
rake aborted!
LoadError: No such file to load -- jobs/scheduled/pending_flags_reminder.rb

Do you have an non-standard plugins installed?

1 Like

Only ones from github

Do they all start with


Yes absolutely! They are all from github.

Virtually every plugin in the world comes from github. They are not all maintained by What plugins do you have?


Remove all plugins and rebuild.

After that, start enabling just the ones you absolutely need, one by one.


Do you see all the plugins that do not start with You need to comment those out by putting a # at the beginning of the line.

Then rebuild and see that it works.

After that, you can uncomment them one at a time.

But you should probably do what @falco said instead.


Okay got it thanks. I’ll try doing the same.